Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
UCS-HD Discovery fails with error 551 and 555 - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • UCS-HD Discovery fails with error 551 and 555
KB0726469

UCS-HD Discovery fails with error 551 and 555


2751 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

UCS-HD pattern steps fail with errors "551 - Authentication failed" or "555 - Session not found."

Release

All currently supported environments.

Cause

Incorrect applicative username/password combination.

The communication via the pattern to the UCS device uses http(s) requests. The username/password can be tested against the target using a POST tool of your choice.

The following would need to be passed to the chosen tool to confirm username/password (remember replace userName, password, and ip of UCS device with necessary values):

Content/Body: "<aaaLogin inName="userName " inPassword="password" />"
ContentType: "application/xml"
Charset: "UTF-8"
Target: https://<ip_of_UCS_device>/nuova

Alternatively, authentication could be tested via either Windows powershell or Linux curl commands.

Windows Powershell:

[System.Net.ServicePointManager]::ServerCertificateValidationCallback = {$true}
Invoke-WebRequest -Uri "https://<ip_of_UCS_device>/nuova" -ContentType "application/json" -Method POST -Body '<aaaLogin inName="userName " inPassword="password" />'

Unix\Linux Curl:

curl -d '<aaaLogin inName="userName " inPassword="password" />' -H "Content-Type: application/json" -X POST https://<ip_of_UCS_device>/nuova

Url path not available:

Per Cisco's "Cisco UCS Manager XML API Programmer's Guide" the url for the API should be https://<ip_of_UCS_device>/nuova. If this url is not present communications will fail.

Resolution

Create applicative credential with correct username/password combination and perform discovery again. Usernames and passwords are case sensitive. If the URL is not available, contact the UCS admin or Cisco support to complete setup of the target UCS device.

Related Links

Cisco UCS-HD document:

  • Cisco Unified Computing System (UCS)-HD device discovery

The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

Attachments

Attachments

No attachments found

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.