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When a user completes a task survey using Legacy surveys, the State of the task survey stays in "Requested" instead of transitioning to a State of "Completed" - Support and Troubleshooting
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  • When a user completes a task survey using Legacy surveys, the State of the task survey stays in "Requested" instead of transitioning to a State of "Completed"
KB0726449

When a user completes a task survey using Legacy surveys, the State of the task survey stays in "Requested" instead of transitioning to a State of "Completed"


467 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms


  • All task_survey records which were completed by their respective assigned users are staying in a State of "Requested" instead of transitioning to a State of "Completed".

Release


  • Kingston Patch 7

Cause


After a thorough investigation across multiple teams of Product Owners, it is our recommendation that the user move to the current Survey Management application, as the future of Survey Management lay in the current application, versus in legacy surveys.

Resolution


As mentioned above, it is our recommendation that the user migrate to the current Survey Management application.

If the user is not ready to move to the current Survey Management application, here is a possible suggestion which could help with this behavior:

To prevent this behavior from happening in the future (a fix-forward option), perhaps the user could create a Business Rule with a query string where the Survey is the "General Survey" Survey and find a current.response on the task on the task_survey table. It is using the Task ID from the survey_response table and making a connection to the sys_id on the task_survey table to the 'task' field. Once these two match, it will set the state to "Completed". 

As such a Business Rule would be custom, writing and testing it would be something that the user and their development team would handle, as Support engineers are experts in OOB behaviors, and specialize in resolving OOB break-fix behaviors. Unfortunately, the debugging and implementing of customizations like this is not in Support's area of expertise.

If the user would prefer to migrate to the current Survey Management application, here are some helpful documents to assist with the migration process: 

  • Legacy survey migration

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