Issue
Impersonation is failing for users who have the impersonator role. Not all users may be affected, however users who recently received the role may see "No matches found" in the user drop-down menu on the impersonation dialog box.
Release
All current releases
Cause
This can occur when orphaned records, or records where the user is empty, exist in the User Roles [sys_user_has_role] table. Orphaned records should never exist on the sys_user_has_role table, and they can cause issues if they do.
Resolution
To determine if you may be running into this issue, pull up the following list in the affected instance (where "instance_name" is your instance) and see if any records populate:
https://instance_name.service-now.com/sys_user_has_role_list.do?sysparm_query=userISEMPTY
If there are results for this query, export the list to XML and then delete the orphaned records.
NOTE: Please make sure that you check with the customer to make sure this is OK before performing any actions.
Related Links
Impersonation issues can occur for many reasons, this being one of them. If you are still having issues, here are some additional resources that may help your troubleshooting efforts:
KB0713041 - Cannot impersonate a user (redirected to login page)