Issue
Symptoms
Knowledge block user criteria is not working
User criteria in portal is not working
Cause
The KB Article Page was customised
The UI page is using a custom widget
Resolution
Revert the "KB Article Page Widget" to the out-of-box (OOB) version
Revert the widget used by your UI page where user criteria is not working. It is recommended to use the OOB version of the widget.
- Go to the Portal page having the issue
- Click Ctrl + Right-click on the page and it will give you a list of options
- Choose Instance in Page Editor and check the Widget if it is a customised version of the widget
- Modify the UI page to use the out-of-box (OOB) widget and Save
- If you have not added a custom version and have modified the out-of-box (OOB) version, you need to go to the platform or advanced view.
- In the navigation bar, type in sp_widget.list to go to the list of Service Portal widget records.
- Filter in the Name or the sys_id of the widget
- In the Versions related list, select both Custom (current) and Upgrade version
- Click on Action on selected rows > Compare > Revert to Selected version which is the OOB version
- Save.