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Description


CI Class Manager does not load.

Steps to reproduce


  1. Navigate to "Configuration > CI Class Manager".
  2. The page does not load.

Root Cause


The CI Class Manager checks if there is an upgrade in progress before loading. The sys_schema_change is queried as part of this check. It may take a long time to check on upgrade status if the table is very large and does not have an index on sys_schema_change(started, finished, duration).

This is also seen on PRB1255465. 

To confirm this is the root cause:

  1. Navigate to "System Diagnostics > Upgrade Monitor".
  2. Upgrade Monitor will not load either, as it performs the same query.

Solution


Add the following index:

  • table: sys_schema_change
  • columns: started, finished, duration

Additional Info


Additional information and related errors can be found on following KBs:

Article Information

Last Updated:2019-05-21 11:52:11
Published:2019-02-13