Description
Symptoms
After a clone is performed, it was discovered that latest version of a store app is not available on the target instance. The "Update" button is disabled when it should be available.
Release
All releases can be affected.
Cause
This is due to the target instance not being populated as an entitlement in the https://store.servicenow.com site.
Resolution
The resolution would be for your ServiceNow admin go to the URL below:
https://store.servicenow.com/sn_appstore_store.do#!/store/myapps
Then click on manage entitlement and then select the target instance that was cloned.