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Reference Fields like 'Requestor', 'Assignment group', and 'Assigned to' that are referencing to sys_user, sys_user_group are not available on the form. - Support and Troubleshooting
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  • Reference Fields like 'Requestor', 'Assignment group', and 'Assigned to' that are referencing to sys_user, sys_user_group are not available on the form.
KB0725874

Reference Fields like 'Requestor', 'Assignment group', and 'Assigned to' that are referencing to sys_user, sys_user_group are not available on the form.


1129 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Reference Fields like 'Requestor' (a reference to sys_user table), 'Assignment group' (a reference to sys_user_group table), 'Assigned to' (a reference to sys_user table) are not visible to non-admin users (than admin) on a ServiceNow Form.

However, all 'admin' users can see these fields on the form.

Release

All releases

Cause

These affected fields like 'Requestor', 'Assignment group', and 'Assigned to' are referenced to user(sys_user) and groups (sys_user_group) table. If the users do not have access to the User/Group table, then the referenced fields from the User/Group table will not be visible to such users on the form.

Resolution

Create the necessary Read/Write ACLs on Group(sys_user_group) and User(sys_user) tables to grant access to other role users so that the non-admin users can have access to these fields on the forms.


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