Issue
Problem
It was reported not expected behavior for Emails to be sent out from non production instances.
Some administrators expect their development or test instance to behave like a sandbox.
Symptoms
When enabling the email properties on your non-production instance
- Emails are sent out to the recipients
- Emails are received into the instance
Cause
All ServiceNow instances get provisioned with an Email account, not only production instances.
Resolution
After an instance is cloned or provision, the email sending/receiving are disabled to prevent emails from accidentally being sent out to real recipients.
It is important to notes that once the email sending/receiving are enabled, emails will be sent out.
Before enabling the email sending/receiving, ensure to correctly set "Send all email to this test email address (non-production testing)" to an email for testing purposes. Otherwise, real recipients will receive emails.
"Send all email to this test email address (non-production testing)" specifies the comma-separated list of email addresses to which the instance sends all email messages. Typically used in non-production instances for testing purposes. This means all emails are sent to these emails instead of the real recipients.
Warning: Before enabling the email properties, ensure to correctly set "Send all email to this test email address (non-production testing)" to an email for testing purposes. |