Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Dependent Choice List Values are shown "blue" in the list view for a table in child domain - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Dependent Choice List Values are shown "blue" in the list view for a table in child domain
KB0725678

Dependent Choice List Values are shown "blue" in the list view for a table in child domain


766 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms


Dependent Choice List Values are shown "blue" in the list view for a table in child domain

Release


All Supported

Cause


Dependent choice is not in the child domain

Resolution


Make sure that all dependent values are in the child domain

Additional Information


Creating Domain-Specific Choice Lists

For choice list values, as for other UI components like lists, forms, sections, and so on, domain separation also determines which records appear on a page.

  • If there is a choice in the current domain, then it is used.
  • If there is no choice in the current domain, then the choice that is in the closest parent domain is used.
  • If no choice is found in the current domain or any parent, then the form that is in the global domain is used.

This logic applies to choice list values as a set. As soon as one choice list is found for the relevant table and field, then only that set of choices appears in the drop-down list.

Note
Note: Administrators should ensure that choices are unique across domains to prevent administrative confusion in the global domain.

The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.