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Symptoms


Requested Item is not receiving the attachments from the Catalog Item view.

Release


Jakarta Patch 10

Cause


current.update(); in a before Insert business rule.

Resolution


> When a Request is submitted for a Catalog Item, the CatalogTransactionCheckout will carry the process and create a new REQ (request).
> In this process, it creates a 'sys_attachment' entry is created with table name: 'sc_cart_item' and table sys_id: sys_id of the Cart Item.
> When the user click on "OrderNow" or "Submit", the same 'sys_attachment' entry is updated with the table name: 'sc_req_item' and table sys_id: sys_id of the Requested Item(RITM).

Reason: The 'sc_cart_item' is converted to a 'sc_req_item' Requested Item(RITM) after submission.

But if there is a current.update(); on the Requested Item table, the sys_id of the RITM is inserted through the business rule and not the CatalogTransactionCheckout.

Remove the current.update(); or disable the Business rule to fix the issue.

 

 

Article Information

Last Updated:2019-05-21 11:51:36
Published:2019-02-05