Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Record Producer submitting a blank record. Variable values are not mapped to the fields on the target record created. - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Record Producer submitting a blank record. Variable values are not mapped to the fields on the target record created.
KB0725629

Record Producer submitting a blank record. Variable values are not mapped to the fields on the target record created.


2378 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms


Record Producer creating blank record.

Release


London Patch 4 Hot Fix 2

Cause


Using a deprecated widget in the Service portal causing an issue with variable mapping.

Resolution


> Navigate to the service portal ex: /sp
> Open the Record Producer and verify the widget on the instance.
(hold cntrl on your keyboard and click on the Record Producer form will display the name of the widget).
> Make sure the widget is OOTB 
or
> If it is a custom widget, verify that it was built using an OOTB valid "SC Catalog Item" widget.
>There is a "SC Catalog Item Deprecated" widget which has been deprecated after Jakarta.
> If the instance is upgraded to a latest version after Jakarta, the custom widget might cause issues.

So, if your service portal widget is build using this deprecated widget,make sure to apply the customization over the valid "SC Catalog Item" widget.

 


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.