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Symptoms


Steps to reproduce:

  • Service Catalog > Maintain Cart Layouts
  • Expand - Target Type: Browser Widget
  • Click on "Item Ordering Widget (Order Guide)"

Notice that only "Components" section/tab is displaying. Now change the Target field to "Shopping Cart Widget", more sections will be available. 

Release


All releases

Cause


This is the designed behavior behavior in the platform.

There is a Client Script which is hiding all SECTIONS with empty fields: 
"hideEmptyScLayoutSections
https://<instance-name>.service-now.com/nav_to.do?uri=sys_script_client.do?sys_id=ca718da2d7203100f2d224837e61038b 

These sections are empty when Target is "Item ordering widget (Order Guide)" because below UI Policy is hiding the FIELDS in them: 
"Show Relevant Fields for 'Item Ordering Widget (Order Guide)'" 
https://<instance-name>.service-now.com/nav_to.do?uri=sys_ui_policy.do?sys_id=b7d4d68537403100fcfbe81d6e41f18c 

In a nutshell, the UI Policy is hiding the FIELDS from these sections and the Client Script is hiding the SECTIONS with empty fields. 

Resolution


Customers can override this behavior by de-activating or modifying this client script and UI policy, however this will not be supported because it is can cause unexpected issues.

 

Article Information

Last Updated:2019-02-04 10:09:00
Published:2019-02-04