Issue
Ensure that approval emails are automatically sent to approvers for requested items by following the steps in this article.
Release
All Releases
Cause
The system fails to send approval emails to approvers for requested items, contrary to the expected behavior of automatically notifying them via email. For any email to be sent from your instance, an email notification needs to be defined.
The cause is because there is no notification defined for approval records for RITMs.
Resolution
To define an email notification:
1. Go to System Notification > Email > Notifications
2. Select New.
3. Choose the table, Approval [sysapproval_approver]
4. Complete the following fields as necessary for your instance:
- Name
- Send when
5. Enter the Condition: [Approval for.Number][starts with][RITM]
6. Complete the following fields:
- Who will receive
- What it will contain
7. Select Submit
8. Test the results.