Issue
In the Request or Requested Item fields, there is an inconsistent Requested For value. When submitted, the Requested For value is empty.
Cause
Seeing inconsistent or empty values in the Requested For field is due to the Order Guide Widget being deprecated or customized.
Resolution
To verify if the Order Guide widget was customized or deprecated, do the following:
- On the Service Portal Order Guide page, use the shortcut Ctrl + right-click.
- Select Instance in Page Editor and verify if the out-of-box (OOB) widget SC Order Guide is used.
- If the widget in use is customized or deprecated, revert the customizations or use the out-of-box widget.
Note You can also verify this in the [sp_widget] table.