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Issue


When you open an RITM record in Service Portal "Form" Widget, the Variable values in variable editor are not visible.

If you try to enter values and save, they are not saved.

If you check the same record in the backend sc_req_item table, the values are present in the variable editor.

Cause


Custom widget used in the Service Portal UI Formatter "com_glideapp_servicecatalog_veditor"

Resolution


Check the Service Portal UI Formatter and make sure you have OOTB widget "sp-variable-editor" configured and not any customized widget

Steps: 

  • Navigate to list "sp_ui_formatter.list"
  • Open the record with the name "com_glideapp_servicecatalog_veditor"
  • Check the widget used. It should be "sp-variable-editor"

Note: Though some customers have OOTB widget "sp-variable-editor" in the UI formatter, make sure that the widget version is OOTB.

Article Information

Last Updated:2019-01-31 00:56:23
Published:2019-01-30