Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Macro variable does not show up on the catalog task form - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Macro variable does not show up on the catalog task form
KB0724985

Macro variable does not show up on the catalog task form


1482 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Macro variable does not show up on the catalog task form

Cause

Macro variable is not set to Global and it is not added to the catalog task form in any Catalog Task activity of the workflow which is associated to the catalog item.


Resolution

In order to display the Macro variable on the catalog task form, please perform the following steps:

1. Mark the Macro variable as Global by checking the Global option on the variable form.

2. Select the Macro variable and add it to the catalog task form in any Catalog Task activity of the workflow which is associated to the catalog item. You could add the variable to the catalog task form using the field "variables on Task Form" in Catalog Task activity.

For more details about the field "variables on Task Form" in Catalog Task activity, please refer to the Catalog Task workflow activity documentation https://docs.servicenow.com/csh?topicname=r_CatalogTask.html&version=latest.




The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.