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Symptoms


Cloud Management Portal, the User tries to launch a Stack and it errors as the "User or Group Quota Exceeded" even the User have Quota available

Environment


  • ServiceNow instance with  any version with CMPv2 enabled

Steps to Reproduce


  •  Log into the instance 
  • Create a User and Associate with a Group which is in state Active=True 
  • Assign "cloud_admin" & "cloud_designer" roles to the user 
  • Impersonate with the newly created User 
  • Verify the user could able to launch a stack 
  • Navigate >> User Administration >> Groups >>Verify the Group which associated with the Cloud User and modify the state to Active=False
  • Navigate >> Cloud Management >> Cloud Admin Portal >> Govern >> Quotas >> Verify the Min and Max Quota provided to the Group  
  • Navigate >> Cloud Management >> User Portal >> Launch a Stack >> Fill the details and click on Submit >> It will error 
  • Below error observed in the Sys log 
checkQuota: Group is not present or Active Groupname, b43d00e5db04a7c0eb4af9771d961943: no thrown erroroutputParams = {"inputMap":{"catalogItemId":null,"contextKey":null,"ciInstanceId":"null",
"userData":{"userId":"adeaa5a7db17df00a6a3547adc96191d","userName":"testuser",
"groupId":null,"groupName":null,"groups":null,"roles":null},"orderId":null,"policyExecutionId":"18d72ad4db9ba7c0a47550d3dc961992","stackId":null,"entityId":"c0c8d2d0db1ba7c0a47550d3dc96190a","formData":
  • Looking at above logs, it is observed that the User is populating correctly but the Group is populating as Null  

Cause


  • The Group associated with the user is in Active=False state

Resolution


  • Log into the instance 
  • Navigate >> User Administration >> Groups 
  • Filter the Group name in the Name field 
  • Click to open the Group and check the Box Active to make the Group Active  

         

  • Launch the stack and it will be successful 

 

Article Information

Last Updated:2019-06-29 05:55:03
Published:2019-06-29
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