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Symptoms


When you tried to change an application/records (for example: UI page '$pwd_success), you get a message "This item is read-only based on its protection policy".

Release


 Any

Cause


Some application code shipped with the ServiceNow system requires special protection like a read-only protection policy which prevents anyone from modifying an application file or its related record.

Resolution


There are two option:

  1. create a change request for ServiceNow employee to Disable read-only Protection policy for the application or records.
  2. Export / edit / re-import, you could follow the steps below: (for example: edit UI page '$pwd_success')

-Export record as XML: You can right click on the header of the UI Page record > Export > XML (This record).

-Adjust changes in XML

-Import XML back into instance: right click on header of the UI Page records > Import XML

 

 

Additional Information


You could check out this KB0717297 for an additional example regarding the same.

Article Information

Last Updated:2019-02-16 15:25:58
Published:2019-02-16