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Symptoms


Workflow is stuck on the "Wait for Condition" activity even after the result was 'true'.

Release


London Patch 2

Cause


Workflow was cancelled at the same time when "wait for condition" was evaluated

Resolution


 

"Wait for Condition" activity will evaluate every time when the record associated to the workflow is updated.

This issue might occur in 2 different ways:

1. Workflow might be cancelled when there is a Business rule that executes on the same condition which was defined on the "wait for condition" activity.

> Look for Business rules that contain "cancelWorkflows()" method and verify the conditions.

 

2. Workflow is not cancelled but just stuck on the "wait for condition" activity after the condition is met.

> Look for a Business rule with "setWorkflow(false)" method which disables the running of business rules, script engines and audit.

 

Article Information

Last Updated:2019-05-21 11:50:59
Published:2019-01-24