Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Variables are deleted when an item is ordered from a custom WebService - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Variables are deleted when an item is ordered from a custom WebService
KB0724349

Variables are deleted when an item is ordered from a custom WebService


730 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms


All the records with empty 'cart_item' field in 'sc_item_option' table and all the records in 'sc_item_option_mtom' table are erased

Release


London Patch 3

Cause


This is a known error in the platform and a problem ticket PRB1320482 was created and is fixed

Resolution


The issue occurs when a custom scripted web service is used to order an item.

In scripted web service, if a custom cart name is passed to the cartJS API and the item is ordered using orderNow() api,


(i.e)
var cart1 = "cart_" + gs.generateGUID() ;
var cart = new sn_sc.CartJS(cart1);

then that web service deletes all the records with empty 'cart_item' field in 'sc_item_option' table and all the records in 'sc_item_option_mtom' table

 

This issue is logged in the problem ticket PRB1320482 and is fixed.

 

WORKAROUND:

The workaround for the issue is to add the following details in the Request body,

var cartName = gs.generateGUID();
var itemGuid = gs.generateGUID();

request_body.get_portal_messages= "true";
request_body.sysparm_cart_name = cartName;
request_body.sysparm_item_guid = itemGuid;
request_body.sysparm_no_validation = "true";

 

 


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.