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Users unable to load ServiceNow until logout and login back again after enabling "GRC: Vendor Risk Management" Plugin - Support and Troubleshooting
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KB0724190

Users unable to load ServiceNow until logout and login back again after enabling "GRC: Vendor Risk Management" Plugin


715 Views Last updated : Jul 22, 2025 public Copy Permalink
KB Summary by Now Assist

Issue

Users who are logged in to their instance may see an error "Security constraints prevent access to requested page" when navigating to modules/applications after the plugin "GRC: Vendor Risk Management" has been activated. Users will not be able to navigate away from their current page. Users who log in to the instance after the activation of the plugin "GRC: Vendor Risk Management" will not be affected.

Steps to reproduce:

The issue is reproducible on the releases: Jakarta Patch 10, Kingston Patch 11 & London Patch 3

Log in to the instance before plugin "GRC: Vendor Risk Management" is activated. In another browser, login as an admin user and activate the plugin "GRC: Vendor Risk Management Go back to the browser in step 1 and attempt to navigate to any module/application. The message - "Security constraints prevent access to requested page" will be displayed





Release

Jakarta Patch 10, Kingston Patch 11 & London Patch 3

Cause

As per the documentation for "Activate  Risk Management", activating the Vendor Risk Management plugin also installs the Explicit Roles plugin. Please refer to Components installed with Vendor Risk Management for the changes in roles. The change in roles will require the logged-in users to log out and log in again so that the changes in the role will be applied.

Resolution

To resolve the error message, logged-in users will need to log out and log in again


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