Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Inconsistent behavior between instances with adding snc_internal role to new users after activating Explicit Roles plugin - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Inconsistent behavior between instances with adding snc_internal role to new users after activating Explicit Roles plugin
KB0723782

Inconsistent behavior between instances with adding snc_internal role to new users after activating Explicit Roles plugin


2217 Views Last updated : Jan 9, 2025 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms


Inconsistent behavior between instances with adding snc_internal role to new users after activating Explicit Roles plugin

On some instances the snc_internal role is added to the new user upon login, which is as documented in the online docs link below. 

On other instances, the snc_internal role is added just by loading the sys_user record by any user

Cause


In addition to user login, snc_internal role can also added to the user role as part of the Resource Management plugin functionality by the View Calendar UI Action on the sys_User form

Additional Information


  • Explicit roles plugin

Release

Any release supporting Explicit Roles plugin

Resolution

- As per the Docs link below, for new Users, snc_internal role is inserted into the User Roles when they first login after plugin activation
- In addition, Resource Management plugin if activated, also adds the snc_internal role (if missing) to the User Role when loading the sys_user form for the user. This is out of box functionality and is processed by View Calendar UI Action on the Sys_user form when the form loads.


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.