Issue
In Service Portal, sysparm_item_guid does not work.
Symptoms
Use of sysparm_item_guid in the client scripts for getting the sys_id of the current catalog item works perfectly fine in Platform UI. However, the same script fails to retrieve sys_id in Service Portal.
Cause
The reason the same client script doesn't fetch the sys_id of the current item in Service Portal is because there is not any element called sysparm_item_guid in the Service Portal DOM UI.
Resolution
The client script looks for a parameter, sysparm_item_guid.
This parameter is not available in Service Portal. Instead, use the catalog item sys_id.
If the requirement is to get the catalog item sys_id in Service Portal, you can use of the following API instead of sysparm_item_guid:
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g_form.getUniqueValue();
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To learn more about using this GlideForm API, refer to the product documentation.