Issue
Multiple workflow trigger for same HR case
Duplicate workflow trigger for same HR case
Cause
This can be caused by declaring workflow in two configurations as follows:
1) If the HR record producer has an HR Template with a value in workflow assignment, it will trigger the workflow assigned to the HR template. Sample below
HR Record Producer template:
HR Template:
2) Once submitted, if the HR record also satisfies a workflow because of the workflow conditions, it will trigger the second workflow.
You can go to Workflow Versions > Filter the HR table name in the Table column
Sample condition configuration:
This will cause duplicate workflows attached
Resolution
Modify or remove either configurations
1) Workflow assignment on the HR template, or
2) Workflow conditions