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Description

Symptoms


After adding few items to shopping cart in Service Portal, when user goes to the cart page and click on "Clear Cart" button, the cart was not cleared as shown in the attached screenshot. 

Release


Any supported release.

Cause


  • Below piece of client side code was missing in the out of the box provided "SC Shopping Cart" widget due to customization,

 

c.clearCart = function() {
spModal.confirm(c.data.msgs.clearCartConfirmationMsg).then(function(confirmed) {
if (confirmed) {
c.server.get({
action: "clear_cart"
}).then(function(response) {
c.data.cart = response.data.cart;
c.data.cartItems = response.data.cartItems
$rootScope.$broadcast("$sp.service_catalog.cart.update");
spUtil.addTrivialMessage(c.data.msgs.cartEmptiedMsg);
});
}
});
}

 

  • And hence "Clear Cart" button was not functioning as expected on the affected instance.

Resolution


Copy paste the above missing "clear cart" function or revert to the out of the box version. This should resolve the issue. 

Additional Information


SC Shopping Cart widget

Revert a customization

Article Information

Last Updated:2019-08-02 20:55:26
Published:2019-01-15