Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Logout Screen and login screen of an instance is in different language than the one set for the user - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Logout Screen and login screen of an instance is in different language than the one set for the user
KB0723511

Logout Screen and login screen of an instance is in different language than the one set for the user


562 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms


Logout Screen and login screen of an instance is in different language than the one set for the user

An example of a logout screen displaying the content in a different language is as shown below:

EXPECTED: To show content on the logout screen in English

ACTUAL: Shows content on the logout screen in a different language

Release


Jakarta, Kingston, London

Cause


If a user logs into the instance, impersonates the guest user and then changes the language of the guest user to some other language by using the language picker then it will change the language in which the content on the login and the logout screen is displayed.

For Example:

If a user has his preferred language set to English but when he logs into the instance and impersonates the guest user and then switches the language to German, the result would be the content of the login and logout screen will now be displayed in German and not in English.

Note:

This is because, the language in which the content on the login screen is displayed before user authentication is done is the language set for the guest user and hence it takes the changed language. The same is the case for the language used for the logout screen content.

Resolution


  1. The affected user will have to log into the instance
  2. Impersonate the guest user again
  3. Switch the language back to the original/expected language 

By following the above steps, we will reset the language for the guest user and hence resolve the unexpected behavior.

 


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.