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Symptoms


-Mid server using LDAP user and fails with authentication, node logs show cannot connect to LDAP for authentication.

 Error:

-StartupSequencer WARNING *** WARNING *** Could not authenticate user '------------' on the ServiceNow instance

Release


All releases

 

Cause


If a LDAP user in configured in the config.xml of a mid server, Mid server sends a basic authentication request to the instance. Once instance receives this authentication request, Node will send out an authentication request to their LDAP server(If LDAP setup is not using MID server) to authenticate the user based on LDAP server settings. 

If we are using the Node to connect to the LDAP server, we are going to use the NAT'ed IP range to send a request to customer LDAP server. Customer should whitelist the NAT'ed range in their firewall so that the request is succeeds. Failure to connect to the LDAP will cause the mid server not connecting to the instance.

Resolution


-Make sure your connection to LDAP server is successful when using LDAP user for your mid server.

-Allow the NAT range in your firewall that ServiceNow provides so that mid user can successfully authenticate.

 

-Please refer to the following KB0538621 to find most recent information about the source address used for integration.

Article Information

Last Updated:2019-05-21 11:50:21
Published:2019-01-12