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Symptoms


business rule is not copying the variable values to a field in RITM

Release


London

Cause


for (var i in current.variables) { } is not supported in London version.

Resolution


A lot of customers are using a business rule to copy the variable values and paste it in a RITM field. There is a community post that explains the code that copies the variable values and pastes them in a RITM field.

However, it would have stopped working post-London.

The following code is not supported in the London version, as the variable set behavior is changed post-London.

for (var i in current.variables) { }

Please refer to this documentation for more details on accessing variables of GlideRecord for the Task table

https://docs.servicenow.com/bundle/london-application-development/page/script/server-scripting/concept/c_ScriptableServiceCatalogVariables.html

However, as a workaround, we can add the following condition check inside the if loop in the business rule that checks various other condition for the object v

v.getGlideObject() != null

 

Article Information

Last Updated:2019-02-27 07:04:28
Published:2019-01-16