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Description

Symptoms


Global search was not finding the newly created Configuration Item (CI). 

Release


Any supported release.

Cause


cmdb "text index" table got stuck with state "indexing" as shown in the below screenshot and hence this didn't allow the new items to be indexed correctly.

Thus the newly added items were not returned in the Global Search results.

Resolution


A. Change the cmdb "text index" table state to "Ready" 

  1. Log on to affected instance
  2. As an admin navigate to "System Definition=> Text Indexes"
  3. Search for Table=cmdb
  4. Open the cmdb text index record
  5. Change the state to "Ready"


B. Then re-index cmdb table.

  1. On the opened cmdb text index record at above step 4, click on the "Regenerate Text Index" related link
  2. System will ask for your email id, enter your email and click "OK"
  3. You will get an email notification when text index is completed

Note: It is recommended to perform the re-indexing during non-business hours to get the good quality indexes.

Additional Information


Reindex a table without impacting text search results

Regenerate a text index for a table

Article Information

Last Updated:2019-08-02 20:55:48
Published:2019-01-10