Issue
Symptoms
Knowledge article not showing in Service Portal with standard Service Portal plugin
Release
Any release supporting Service Portal
Cause
For standard Service Portal, only one knowledge base is supported. The knowledge article belongs to the knowledge base which is not associated to the knowledge base for the standard Service Portal
Resolution
Enable the plugin for Knowledge Management Service Portal which supports multiple knowledge bases - please refer to the following DOC for details
Additional Information
https://docs.servicenow.com/csh?topicname=knowledge-management-service-portal.html&version=latest