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Unable to download the attachments from activity stream in Service Portal - Support and Troubleshooting
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  • Unable to download the attachments from activity stream in Service Portal
KB0722387

Unable to download the attachments from activity stream in Service Portal


3369 Views Last updated : Jul 24, 2025 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms


Certain users, like the approver on a request, are not able to download the attachment from the activity stream of the approval form (or any other record) in the Service Portal.

Release


Jakarta, Kingston

Cause


The issue may occur due to the approver not having enough roles to grant read access on the [sys_attachment] table.

Resolution


This is a customization to alter OOB system behavior. Customization and implementation assistance are out of the scope of support and the customized scripts, if any, will be skipped during an upgrade.

As a workaround to this, a read ACL can be created on the [sys_attachment] table that would allow users to access the sys_attachment record, subsequently letting the affected user download the record.

  1. Go to sys_security_acl.list (System security > Access control)
  2. Create a new READ type ACL on [sys_attachment] (sys_attachment.none), allowing users to provide read access to sys_attachment records.

The above workaround grants access to the sys_attachment table. Make sure to have thorough testing done to ensure it does not interfere with any other business logic.

Additional Information


Create an ACL


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