Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Fix page access restriction error caused by security constraints in Service Portal - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Fix page access restriction error caused by security constraints in Service Portal
KB0722359

Fix page access restriction error caused by security constraints in Service Portal


4106 Views Last updated : Oct 1, 2025 public Copy Permalink
KB Summary by Now Assist

Issue

If you have the snc_external role in Service Portal, you may see the following error when navigating to certain pages: "Security constraints prevent access to requested page". This is likely because of security selections in the Public Pages [sys_public] table. 

 

Release

All supported releases

Cause

This error message displays if the $sp page is set to non-public in the Public Pages [sys_public] table. 

The error occurs when the Active checkbox on $sp is not selected. 

Resolution

Log in as an admin role and do the following:

  1. In the filter navigator, go to sys_public.list.
  2. Find the page named $sp.
  3. Select the Active check box.
  4. Save the record.

Related Links

Make UI pages public or private


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • Cookie Preferences
  • © 2025 ServiceNow. All rights reserved.
We use cookies on this site to improve your browsing experience, analyze individualized usage and website traffic, tailor content to your preferences, and make your interactions with our website more meaningful. To learn more about the cookies we use and how you can change your preferences, please read our Cookie Policy and visit our Cookie Preference Manager. By clicking “Accept and Proceed,” closing this banner or continuing to browse this site, you consent to the use of cookies.