Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
How to get Password Reset working with LDAP/AD - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • How to get Password Reset working with LDAP/AD
KB0721415

How to get Password Reset working with LDAP/AD


1153 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms


Testing Windows Credentials would fail with an error message : "Module Credentials could not be found".

Cause


Installation of MID server on the unsupported Windows version. This was noticed on Windows 10 workstation, but may be applicable for any unsupported version.

Resolution


Install the mid server on a supported version. Below is the requirements from London version, but refer the instance version for the actual mid server requirements.

MID Server supported systems : 
https://docs.servicenow.com/csh?topicname=r_MIDServerSystemRequirements.html&version=latest 

Windows server: To discover Windows-based servers, run Service Mapping patterns, or execute Orchestration commands on Windows devices, the MID Server must be installed on a Windows server. The MID Server supports all Windows Server 2008, 2012, and 2016 editions, virtual machines, and 64-bit systems.

Note:
 .NET Framework version 3.5, 4.0, 4.5, 4.6, or 4.7 is required for Service Mapping support and for Windows pattern-based discovery.

 


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.