Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
IP Firewall devices are updated as IP Router class. This may be the case with other SNMP devices as well. - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • IP Firewall devices are updated as IP Router class. This may be the case with other SNMP devices as well.
KB0721406

IP Firewall devices are updated as IP Router class. This may be the case with other SNMP devices as well.


1786 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms


Firewall devices that are already discovered would be reclassified as Routers. This may be the case with other SNMP based devices.

Also, SNMP-Classify system OID information.

 

Cause


sysObjectOID is primarily used for SNMP device classification. If sysObjectOID is not returned in the SNMP-Classify input payload or not been added to the SNMP OID list, then "SNMP-Classify" sensor would scan through some of the input payload OIDs to construct some capabilities ( ex : routing, printing, switching, etc to name a few ) which would then be used to classify a device further.

During this phase, sometimes sysObjectOID is not returned due to timeout and this may lead to the device classification based on the capabilities.

Missing sysObjectOID may look like this. All other OIDs are present, but the systemObjectOID is missing.

<system oid="1.3.6.1.2.1.1"> 
<sysName oid="1.3.6.1.2.1.1.5" type="SnmpOctetString">apcfwven1b</sysName> 
<sysUpTime oid="1.3.6.1.2.1.1.3" type="SnmpTimeTicks">1043305934</sysUpTime> 
<sysDescr oid="1.3.6.1.2.1.1.1" type="SnmpOctetString"> 
IPSO apcfwven1b 6.2-GA083a02 releng 1 08.15.2013-191852 i386 
</sysDescr> 
</system> 

Resolution


Add "request_interval" snmp probe parameter with a greater value and see if this fetches the sysObjectOID. If this OID is returned and present in the SNMP OID list, the device should be classified accordingly.

 


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.