Issue
Workflow still progressing even when user approved or rejected
Workflow skipped approval activity results
Did not received any approval or rejection notification
Cause
There is a custom before query business rule preventing access to the record, sysapproval_approver, or sysapproval_group table
Resolution
1. As an administrator, turn on 'Debug Business Rule (Details)' by selecting it from the application navigator
2. Perform the approval or rejection on the record. Check the debug logs generated after the problematic approval step. The logs should include all business rules that ran after your have approved or rejected the record.
3. Check if there were any Before query business rules
Try deactivating the business rule to test if this is the only cause of your issue