Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Forbidden Username/password Combo error with Outbound Rest Call - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Forbidden Username/password Combo error with Outbound Rest Call
KB0720934

Forbidden Username/password Combo error with Outbound Rest Call


20205 Views Last updated : Feb 25, 2025 public Copy Permalink English (Original)
  • English (Original)
  • Japanese
KB Summary by Now Assist

Issue

When trying to issue a REST outbound call from UI to an endpoint, you witness the error “Forbidden username/password combo” in the response message”

Symptoms:

You will recognize this error when you go to the configured Outbound Rest call -> Select the http method (Get or Post) and then issue the Test command

The same error is visible from the Outbound HTTP requests as well

../../image.png

 

Cause

Possible cause of the behavior is the “user agent” field value in the http header of the request is not liked by the endpoint leading to this access denied error message in the response

Actual Http Header Request from HTTP log on UI:
{Accept=application/json, Content-Type=application/json, Authorization=Basic XXX, User-Agent=Jakarta Commons-HttpClient/3.1, Host=XXX}

Issue is identified when we were trying to issue CURL command from the App Physical host with the same header as the one passed to the endpoint from UI when you click on the est button in the Outbound REST call.

 

Initial CURL Used with the default User Agent Value:

Failed

curl -v \
> -H 'Accept: application/json' \
> -H 'Content-Type: application/json' \
> -H 'Authorization: Basic XXXXXX' \
> -H 'User-Agent: Jakarta Commons-HttpClient/3.1' \
> -H 'Host: XXXXXX' \
> -X GET XXXXX

 User-agent changed to “ServiceNow” for testing and you see a success response


Success:

 curl -v \
> -H 'Accept: application/json' \
> -H 'Content-Type: application/json' \
> -H 'Authorization: Basic XXXXXX' \
> -H 'User-Agent: servicenow' \
> -H 'Host: XXXXXX' \
> -X GET XXXXX

 

Similarly, when adding the user Agent value as "ServiceNow" in the Get/POST method Header of the REST call from UI, you see a successful response with the expected data 

../../../Desktop/Screen%20Shot%202018-12-17%20at%209.21.25%20PM.png

 

Resolution

The endpoint for some reasons doesn’t accept the value of the “User-Agent” field in the Header of the Outbound REST call. Changing this to "ServiceNow" in the outbound REST Header will resolve the error. 


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.