Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
State field does not display for Security Incidents for Non-Admin users when field is manipulated from Script Include which is in a scoped application - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • State field does not display for Security Incidents for Non-Admin users when field is manipulated from Script Include which is in a scoped application
KB0720853

State field does not display for Security Incidents for Non-Admin users when field is manipulated from Script Include which is in a scoped application


423 Views Last updated : Jul 24, 2025 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms


State field does not display for Security Incidents for Non-Admin users when field is manipulated from Script Include which is in a scoped application

Release


All

Environment


Security Incident Response (com.snc.security_incident) plugin is activated

Cause


Field is manipulated from Script Include which is in application specific scope, but user user does not have execute operation access to client_callable_script_include Type ACL

Resolution


Add the User Role - ITIL to execute ACL of type:client_callable_script_include in the same scope.

Here is a link to the ACL, replace <instance_name> with the actual instance name:

https://<instance_name>.service-now.com/sys_security_acl_list.do?sysparm_query=operation.nameSTARTSWITHexecute%5EnameLIKEsecurity 

Note: For the Security Incident scoped app, OOB ACL sys_id=196bd0450b2132008f9108e3c5673aee 


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.