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Submitting a request from service portal throws errors like 'Evaluator: java.lang.NullPointerException'  as a result of custom Business Rule that is referencing DateTime type fields - Support and Troubleshooting
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  • Submitting a request from service portal throws errors like 'Evaluator: java.lang.NullPointerException'  as a result of custom Business Rule that is referencing DateTime type fields
KB0720724

Submitting a request from service portal throws errors like 'Evaluator: java.lang.NullPointerException'  as a result of custom Business Rule that is referencing DateTime type fields


814 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms


Submitting a request from service portal throws errors like 'Evaluator: java.lang.NullPointerException' with possibly failing widgets like Ticket conversation and errors/messages in log similar to 'com.glide.glideobject.GlideDateTime.addSeconds(GlideDateTime.java:1172)'  and 'SEVERE *** ERROR ***performing addSeconds with invalid GlideDateTime' 

Release


Any release supporting Service Portal

 

Cause


In most cases there was a customized business rule referencing DateTime type fields and causing issue

Resolution


The issue was due to a customized business rule which got resolved after customer deactivated the business rule or fixed the script where the datetime field was referenced. A hint to find which business rule is causing the problem maybe to check the Updated field for any recent updates. 

 


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