Issue
In the case where the 'Requested for' field is not cleared out when the user clicks on 'Cancel' from the Order Confirmation screen.
Example Scenario:
As any user (User A), when you add an item to the cart and click on 'Proceed to checkout, it would give the Order Confirmation screen. At this point, if we click Cancel and add another item to the cart and do Proceed to Checkout, the requested for still shows User B.
Release
All Releases
Cause
This is expected behavior because, when you change the requested for to User B, if we check for DEFAULT cart in sc_cart table for User A, the requested for gets updated to User B. Until to clear the cart or submit this request, requested for is User B.
Resolution
Expected Behavior
Related Links
The same behavior is seen even from Service Catalog.