Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
"Requested Record not found" error coming after impersonating any user - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • "Requested Record not found" error coming after impersonating any user
KB0720488

"Requested Record not found" error coming after impersonating any user


3135 Views Last updated : Aug 24, 2022 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms


Impersonator role is not working properly. When impersonating users who have HR read/write roles they are unable to view the HR tickets on portal, message shows up - "Requested Record not found" 

Cause


"sn_hr_core.impersonateCheck" system property value

Resolution


There is a system property - sn_hr_core.impersonateCheck which if set to true creates these issues

/nav_to.do?uri=sys_properties.do?sys_id=7a5330019f22120047a2d126c42e70f0

As documented: HR Properties

sn_hr_core.impersonateCheck : Check Yes to prevent a user impersonating another user with higher access from viewing or editing sensitive information.

Since this was set to true, following OOB ACL will fail due to which issue happens- /sys_security_acl.do?sys_id=3a5370019f22120047a2d126c42e7005

Set this property to false and clear the cache to fix the issue.


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.