Issue
Symptoms
Impersonator role is not working properly. When impersonating users who have HR read/write roles they are unable to view the HR tickets on portal, message shows up - "Requested Record not found"
Cause
"sn_hr_core.impersonateCheck" system property value
Resolution
There is a system property - sn_hr_core.impersonateCheck which if set to true creates these issues
/nav_to.do?uri=sys_properties.do?sys_id=7a5330019f22120047a2d126c42e70f0
As documented: HR Properties
sn_hr_core.impersonateCheck : Check Yes to prevent a user impersonating another user with higher access from viewing or editing sensitive information.
Since this was set to true, following OOB ACL will fail due to which issue happens- /sys_security_acl.do?sys_id=3a5370019f22120047a2d126c42e7005
Set this property to false and clear the cache to fix the issue.