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Target field in External Content Item does not work in Service Portal - Support and Troubleshooting
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  • Target field in External Content Item does not work in Service Portal
KB0720442

Target field in External Content Item does not work in Service Portal


1157 Views Last updated : May 16, 2023 public Copy Permalink
KB Summary by Now Assist

Issue

The Target field in Content Item for External Contents does not work in Service Portal. There are two options for the Target field. a) Within Catalog b) New Window/Tab.

For both options, the external content opens in a new tab.

 

Steps to Reproduce

  1. Create a new Content item.
  2. Select 'External Content' in Content Type.
  3. In the Target Select 'Within Catalog'. Select the desired Catalog item and the Category. Write the External content link in the URL field.
  4. Go to the Service Portal and open the selected Category.
  5. On clicking the Content, it opens in a new Tab. Even after selecting the Target as 'Within Catalog' the External Content opens in a new tab.

Cause

This is expected behavior, as 'Within Catalog' displays the content within the catalog iframe window and as iFrames are not supported in Service Portal, this behavior doesn't work in Service Portal.

Related Links

  • This behavior works fine in Native UI.
  • Define a content item

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