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Description

Overview


The Target field in Content Item for External Contents doesnot work in Service Portal. There are two options for the Target field. a) Within Catalog b) New Window/Tab.

For both the options, the external content opens in a new Tab.


Steps to Reproduce


1) Create a new Content item.

2) Select 'External Content' in Content Type.

3) In the Target Select 'Within Catalog'. Select the desired Catalog item and the Category. Write the External content link in the URL field.

4) Go to the Service Portal and open the selected Category.

5) On clicking the Content, it opens in a new Tab. Even after selecting the Target as 'Within Catalog' the External Content opens in a new tab.

Cause

This is an expected behavior, as 'Within Catalog' displays the content within the catalog iframe window and as iFrames are not supported in Service Portal, this behavior doesn't work in Service Portal.

Additional Information

This behavior works fine in Native UI.

The below link will Define Content Item:

https://docs.servicenow.com/bundle/jakarta-it-service-management/page/product/service-catalog-management/task/t_AddingContentItemServiceCatalog.html

Article Information

Last Updated:2020-09-08 06:03:20
Published:2020-09-08