Issue
Symptoms
When selecting Show XML on the Service Portal Container record, the background image field is empty.
Release
Kingston onwards
Procedure
- Go to sp_container record.
- Right-click on the header.
- Select Show XML.
This will open a window displaying the xml content of the sp_container record. In the xml, the background_image field is empty.
Cause
The background image uploaded on the sp_container record is stored in the sys_attachment table. When you export the xml file, it includes the base64 encoding of the background image file.
Resolution
The reason why the background image shows empty when you right-click and select "Show XML" is to prevent latency/performance issues and to prevent unnecessary download of base64 encoding when the file is not being exported.
This is expected behaviour.