Notifications

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Symptoms


When a user switches language from base language to a different language, additional comments, worknotes and short Description are not translated.

Release


All available release

Cause


Working as expected.

Resolution


When a user switches to a different language,, the custom texts will not be translated. Only the texts which exactly matches with the records entered in the sys_ui_message will be translated. Since the comments, work_notes, descriptions are manually entered custom texts, these will not get translated.

To define your own translations for non journal string fields like description, you can use translated_text. But for that, you will need to manually create you own translations switching to the language you need and entering values in that language to the field. Please refer the following documentation on translate text field type for your reference. But this will not serve your purpose of translating all the descriptions automatically.

Additional Information


https://docs.servicenow.com/bundle/london-platform-administration/page/administer/localization/reference/r_TranslatedText.html

Article Information

Last Updated:2018-12-07 11:39:38
Published:2018-12-07