Issue
Symptoms
Live feed messages appearing in incident forms after a delay of about 5 minutes
Release
All available release
Cause
This is working as expected when you select live_feed is used following for incident updates.
Resolution
The messages do appear in the live feed popup after a delay of 5 minutes. This is the reason why you have a button to refresh the field manually. The delay is set to five minutes for performance reasons.
If you want to use the live feed to post and get messages and worknotes in real time you need to use connect app to follow the incidents. To do the same, you need to set the following property to "collaboration"
glide.live_feed.task_header_button -
https://<instance-name>.service-now.com/nav_to.do?uri=sys_properties.do?sys_id=ae0505429f013100d5f9b3e2957fcf53
Once you do that, if you follow an incident, the collaboration popup would appear in the incident and you can get/post messages in real-time.
Additional Information
Once you set the property to collaboration, live feed in the dropdown will not be available. If you would like to use both "collaboration" and live feed, you can set the same property value to "both".
glide.live_feed.task_header_button -
https://<instance-name>.service-now.com/nav_to.do?uri=sys_properties.do?sys_id=ae0505429f013100d5f9b3e2957fcf53