Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Duplicate Process Flows (Conditions are not working) - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Duplicate Process Flows (Conditions are not working)
KB0719373

Duplicate Process Flows (Conditions are not working)


522 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms


  • Duplicate Flow formatters are seen in all Change Requests. The user was expecting only certain Flow formatters to show under the prescribed conditions added in the condition builder.

Release


  • Kingston Patch 4 Hot Fix 1
  • Kingston Patch 7
  • Kingston Patch 9

Cause


The purpose of the condition builder was misunderstood by the user (further explanation below).

Resolution


The user mistakenly believed that the condition builder on the Flow formatter determined whether or not to display the particular Flow formatter. This is not the case.

Rather, the purpose of the condition builder is "to set the conditions under which the formatter is highlighted as current" ( ref: Process flow formatter ).

The same behavior (seeing duplicate Flow formatters) is reproducible Out of Box (OOB) by creating a new Flow formatter with the same "name" and "label" field values as an already existing Flow formatter.

As there is no OOB functionality which determines (based on conditions) if a certain Flow formatter is displayed or not, it was recommended to the user to kindly reach out to their internal development team to accomplish this customization. Additionally, the user can be referred to Professional Services (note: there is a fee with this service).


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.