Description
Symptoms
Tasks field greyed out for Expedited changes
Cause
Custom Business rule / ACL
Resolution
This is related to how the custom business rule is set.
The condition here is 'current.state.changesFrom('-5')'. From activity stream, we can see the change task did not move from Inactive to a different state until '2018-09-20 18:03:46'. However, we can see from the history, this task was assigned to user on '2018-09-19 11:15:43'. So, between these two times, the user would not be passing the script in the ACL which is checking the field which the business rule sets.