Issue
When accessed in Service Portal, an order guide name is not translated for non-English languages, as well as for record producers or normal catalog items. However, this does not happen on the normal platform service catalog.
Release
All releases
Cause
This is because the name field on the sc_cat_item table is not Translated Text type.
Resolution
To fix this:
- On the sc_cat_item table, in the name field, change the field or dictionary type to Translated Text.
- Make sure the following attribute is included in the field: serializer=com.glide.script.TranslatedTextXMLSerialize
Related Links
For more information, see the product documentation on Translation tables.