Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Order guide name is not translated for non-English languages in service portal - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Order guide name is not translated for non-English languages in service portal
KB0719366

Order guide name is not translated for non-English languages in service portal


364 Views Last updated : May 30, 2025 public Copy Permalink
KB Summary by Now Assist

Issue

When accessed in Service Portal, an order guide name is not translated for non-English languages, as well as for record producers or normal catalog items. However, this does not happen on the normal platform service catalog. 

 

 

Release

All releases

Cause

This is because the name field on the sc_cat_item table is not Translated Text type. 

Resolution

 To fix this: 

  1. On the sc_cat_item table, in the name field, change the field or dictionary type to Translated Text.
  2. Make sure the following attribute is included in the field: serializer=com.glide.script.TranslatedTextXMLSerialize

Related Links

For more information, see the product documentation on Translation tables.


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.