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Unable to create HR cases either from UI Page "case_creation" or via Chat - Support and Troubleshooting
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KB0719317

Unable to create HR cases either from UI Page "case_creation" or via Chat


1106 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms


We have an OOB UI page called "case_creation" that assists in creating HR cases.

This can be either explicitly loaded via "sn_hr_core_case_creation.do" or via Collaboration chat.

You may face occurrence of this issue where the page loads nothing (blank white) with the following browser console error:

angular_includes_1.4.jsx?v=03-02-2018_1305:8 Uncaught Error: [$injector:modulerr] http://errors.angularjs.org/1.4.8/$injector/modulerr?p0=caseCreation
&p1=Error%3A%20%5B%24injector%3Amodulerr%5D%20http%3A%2F%2Ferrors.angularjs.org%2F1.4.8%2F%24injector%2F
...
...

Release


Jakarta, Kingston, London.

Environment


UI15.

Cause


- The UI16 plugin was not activated.

Resolution


  • Installation of UI16 plugin is required for the UI page to work. It is not necessary to use the UI16 theme/ui, but the plugin is necessary to load angular on the case_creation ui page.
  • It's not actually necessary to use UI16 features and you can completely disable it by following the below steps:
    • On filter navigator, go to "User Administration" > "User Preferences".
    • Look for the record with name "use.concourse".
    • Notice it's value is "true". Set this to "false" => logout and log back in.
    • You will see that your UI will be in UI15 mode.

 


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