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Clicking date/time field opens the calendar/date picker doesn't open it near the respective field. - Support and Troubleshooting
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  • Clicking date/time field opens the calendar/date picker doesn't open it near the respective field.
KB0719203

Clicking date/time field opens the calendar/date picker doesn't open it near the respective field.


1846 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

This article focuses on the behavior where the date or date/time field(s) when clicked on the form, the date or date/time picker pops-up on the top left of the form (rather than just below the respective field).

Example: In the below screenshot, clicking on the calendar icon of 'Planned start date' field in 'Schedule' section has opened the calendar/dateTime picker on the top for the same field.

Release

All releases.

Cause

  • The most probable cause is the rendering of duplicate fields on the form (regardless of whether they are in same/different form sections).
  • Even if one section is hidden, the fields will still break as the script runs for date picker once when the form is loaded (and it picks the first date or date/time element rendered)

Resolution

  • Remove the duplicate fields from the form via Configure > Form Layout.
  • Our platform doesn't support multiple occurrences of the same fields on the form as that can cause inconsistent behavior (like above). 

Related Links

Configure Form Layout: https://docs.servicenow.com/csh?topicname=configure-form-layout.html&version=latest


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