Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Unable to view email content from Activity stream on HR Case record - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Unable to view email content from Activity stream on HR Case record
KB0719155

Unable to view email content from Activity stream on HR Case record


4438 Views Last updated : Mar 18, 2025 public Copy Permalink
KB Summary by Now Assist

Issue

HR Case records have been configured to display emails in the Activity stream/log; however, clicking the link (show email details) displays the following errors:

UI errors:

No such parent record

List View errors on sys_email table:

"Read operation on table 'sn_hr_core_case_total_rewards' from scope 'Global' was denied because the source could not be found. Please contact the application admin.

Error Message Read operation on table 'sn_hr_core_case_total_rewards' from scope 'Global' was denied. The application 'Global' must declare a cross scope access privilege. Please contact the application admin to update their access requests.

Error Message Read operation on table 'sn_hr_core_case_total_rewards' from scope 'Global' was denied because the source could not be found. Please contact the application admin.

Error Message Read operation on table 'sn_hr_core_case_total_rewards' from scope 'Global' was denied. The application 'Global' must declare a cross scope access privilege. Please contact the application admin to update their access requests."


Log errors:

Source descriptor is empty while recording access for table sn_hr_core_case_total_rewards: no thrown error 

Release

All releases

Cause

HR Case records have been configured to display emails in the activity stream, which is not configured as such in an out-of-box instance.

For information on how to enable emails to be displayed in the activity stream check KB0719147 - How to configure and display 'Sent/Received Email' in the activity stream/log

The email content cannot be accessed from the Human Resources: Core scope, hence these errors.

Resolution

Create a Restricted Caller Access Privilege record by:

1) Navigating to System Applications ==> Application Restricted Access Privilege.

2) Click the New button and then add the following information:

Source Scope = Global
Source Type = Scope
Status = Allowed
Target Scope = Human Resources: Core
Target Type = Scope.

When the record is created now clicking on the 'show email details' link from the activity stream actually shows the content of the email.

Related Links

Roles can be configured for the Activity stream from the system property (glide.ui.activity.email_roles).


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.